Linux Installation for PostgreSQL May Fail During Software Update

Linux Installation for PostgreSQL May Fail During Software Update

KB ID: 115052  
Cause:
While installing the BDRShield Server on a Linux machine, PostgreSQL installation may fail with an error message “postgresql: unrecognized service”. This issue may arise due to conflicts with background database updates or ongoing software package auto-updates on the Linux machine.
Solution:
Follow the steps below to prevent PostgreSQL installation failure:
1. Ensure that background software updates on the Linux machine are not in progress during the BDRShield Server installation.
2. If PostgreSQL installation fails, perform an on-top installation of BDRShield with the same build setup after the background updates are completed.
3. Verify the successful installation of PostgreSQL by checking that both PostgreSQL and the BDRShield server are running as services.

    • Related Articles

    • BDRShield Automatic Software Update Guide

      KB ID: 99 Overview: The BDRShield offers software updates through manual upgrades for BDRShield Servers (Backup Server and Offsite DR Servers) and automatic upgrades for BDRShield Clients. This guide provides steps for upgrading each component to ...
    • BDRShield Software Upgrade Guide

      The BDRShield provides software updates as follows: BDRShield is now BDRShield - Click to know more Manual Upgrade for Servers BDRShield Backup Server and Offsite DR Server require a manual upgrade when a new version is released. Users must download ...
    • Bulk Agent Installation Using Remote Monitoring and Management (RMM) Software for BDRShield/ BDRCloud

      KB ID: 115230 Overview This guide provides step-by-step instructions to add Windows servers and endpoints to your Remote Monitoring and Management (RMM) software by performing a bulk agent installation. Bulk installations help streamline the ...
    • New Desktop Icon Not Appearing After Automatic Software Update

      KB ID: 50 Cause: The new desktop icon does not appear after an automatic software update, mainly due to system cache. After upgrading the existing installation, the new desktop icon fails to show up. Solution: To resolve this issue, follow these ...
    • Manual Workaround Steps for Software Upgrade in BDRShield Clients

      KB ID: 115051 Overview: This knowledge base article provides manual workaround steps for upgrading Vembu NetworkBackup clients in scenarios where the automatic software upgrade process fails due to issues in retrieving sufficient information from the ...