Troubleshooting: Service Running Without Required Privileges in BDRSuite

Troubleshooting: Service Running Without Required Privileges in BDRShield Backup Server / BDRShield Remote Proxy / BDRShield Agent

KB ID: 117000

Cause

The alert "The service is running in the logon account that does not have the required privileges" occurs when the BDRShield Backup Server / BDRShield Remote Proxy / BDRShield Agent does not have administrator privileges. This privilege is essential for the service logon to install BDRShield Delegation Service (BDS) for Hyper-V backup and BDRShield Backup Agent (BBA) for Disk Image and Files & Folders Backup on the target machine.

Solution

To resolve this issue, ensure that the BDRShield Backup Server / BDRShield Remote Proxy / BDRShield Agent is running with either of the following privileges:
1. Administrator
2. User having administrator privilege

Steps to add the Service logon on your BDRShield Backup Server

Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
  1. BDRShield Backup Server for Virtual Physical Workloads
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.

Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.
For step by step process watch the below video

Steps to add the Service logon on your  BDRShield Remote Proxy

Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
  1. BDRShield Remote Proxy Service
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.

Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.

Steps to add the Service logon on your  BDRShield Agent

Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
  1. BDRShield Delegation Service
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.

Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.
Notes
Note: If you encounter any issues during service restart, please verify the user credentials provided during the logon update.