Error - A Computer That Is Joined To A Server Farm By Users Who Have Permissions In SQL Server To Read From The Configuration Database – SharePoint

Error: Unable to Connect to SharePoint Server Farm Due to SQL Server Permissions Issue

KB ID: 82
Issue:
When attempting to connect to the SharePoint server farm via the Portal Site http://svsweb2:9999, an error occurs. The specific error message states: "This operation can be performed only on a computer that is joined to a server farm by users who have permission in SQL Server to read from the configuration database. To connect this server to the server farm, use the SharePoint Products Configuration Wizard, located on the Start menu in Microsoft SharePoint 2010 Products."
Cause:
This issue arises when the user accounts "UserAccountName" or "Administrator" lack sufficient permissions in the SQL Server contents databases of SharePoint site collections on the machine.
Solution:
To resolve the issue, follow these steps to add the "UserAccountName" to the MSSQL server:
1. Access the SQL SharePoint instance using Management Studio on the server.
2. In the "Object Explorer," navigate to the "Security" tree menu at the bottom. Expand the menu and select "Login." Right-click on it and choose "New Login." Then, enter your login credentials and select "sysadmin" under server roles.